Delay in recurring payment processing

Incident Report for Solidgate

Resolved

This incident, which involved a delay in recurring payment processing, has been fully resolved by the team.
Incident started at 11:01 AM and finished at 11:16 AM. We will follow up with the affected merchants shortly.
This incident has been resolved.
Posted Mar 31, 2025 - 11:38 UTC

Identified

We are currently experiencing a temporary delay in recurring payment processing. All orders are being processed successfully, with only a few CIT orders impacted. We will follow up with the affected merchants shortly.
Posted Mar 31, 2025 - 11:21 UTC
This incident affected: Payment API (Card Payments).