Payment form potential issues

Incident Report for Solidgate

Resolved

The issue has been resolved. Impact was limited to the US region. The payment form is operating normally.
The incident was active from 17:47 to 18:06 UTC. We will reach out directly to affected merchants with a list of impacted orders.
Posted May 06, 2026 - 18:25 UTC

Identified

We have identified a partial performance degradation affecting the payment form. A fix is actively being deployed.
We will follow up separately with a list of affected orders. No action is required.
Posted May 06, 2026 - 18:06 UTC
This incident affected: Solidgate Payment Form.