Blik has issue on their side

Incident Report for Solidgate

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 16:42 UTC

Monitoring

Blik is currently unavailable due to a provider-side issue.

We're in touch with the provider and will provide an update as soon as the problem is resolved.
Posted Nov 03, 2025 - 14:05 UTC
This incident affected: Providers \ Banks \ 3rd party integrations.