Blik has issue on their side

Incident Report for Solidgate

Resolved

Issue involving our 3rd Party partner Blik, has been fully resolved.
Issue started at 2025-11-05 10:17 AM UTC and finished at 2025-11-10 11:30 AM UTC.
This issue has been fully resolved.
Posted Nov 10, 2025 - 14:49 UTC

Monitoring

Blik has high error rates

We're in touch with the provider and will provide an update as soon as the problem is resolved.
Posted Nov 05, 2025 - 10:17 UTC
This incident affected: Providers \ Banks \ 3rd party integrations.