Google Pay has issues on their side

Incident Report for Solidgate

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 17:28 UTC

Monitoring

Google Pay has been restored on Google's side. We will continue monitoring for a short period to confirm stability.
Posted Sep 16, 2026 - 17:12 UTC

Investigating

Due to an issue on Google's side, the Google Pay button fails to initialize and users see an error when attempting to pay. All other payment methods are unaffected. Awaiting upstream resolution from Google.
Posted Sep 16, 2026 - 15:42 UTC
This incident affected: Providers \ Banks \ 3rd party integrations.