Ethoca has issue on their side. No payment processing is affected.

Incident Report for Solidgate

Resolved

The provider has resolved the issues on their end, and all affected prevention alerts were automatically reprocessed.
Posted Nov 07, 2025 - 16:12 UTC

Identified

Our third-party chargeback prevention alert provider, Ethoca, is experiencing an issue on their end. Our team is actively investigating the matter and its impact and is in communication with the provider to resolve it.
Posted Nov 07, 2025 - 14:30 UTC
This incident affected: Providers \ Banks \ 3rd party integrations.