Ethoca has issue on their side. No payment processing is affected.

Incident Report for Solidgate

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 19:01 UTC

Monitoring

Our third-party chargeback prevention alert provider, Ethoca, is experiencing an issue on their end.

Our team is actively investigating the matter and its impact and is in communication with the provider to resolve it.
Posted Jan 14, 2026 - 18:23 UTC
This incident affected: Providers \ Banks \ 3rd party integrations.