Elevated declines on Mastercard

Incident Report for Solidgate

Resolved

This incident has been resolved.
Posted Mar 09, 2025 - 11:20 UTC

Monitoring

We are currently experiencing elevated error rates and increased response times for Mastercard transactions. Our team is actively monitoring the situation and working with relevant partners to resolve it as soon as possible.

We will provide updates as more information becomes available. Thank you for your patience.
Posted Mar 09, 2025 - 09:58 UTC
This incident affected: Providers \ Banks \ 3rd party integrations.