Resolved: Blik Payments potential issues

Incident Report for Solidgate

Resolved

This incident, involving Blik payment service, has been fully resolved by the team.
Incident started at June 30 08:00 AM UTC and finished at July 1 10:32 AM UTC.
Posted Jul 01, 2026 - 11:12 UTC

Monitoring

We're experiencing potential faults in alternative payment method Blik processing. Our team is actively working on resolving this as quickly as possible.

We'll post an update as soon as possible.
Posted Jul 01, 2026 - 10:34 UTC
This incident affected: Payment API (Alternative Payments) and Providers \ Banks \ 3rd party integrations.