Provider Nuvei has issue on their side

Incident Report for Solidgate

Resolved

Issue involving our 3rd Party partner Nuvei, has been fully resolved.
Issue started at 16:35 UTC and finished at 17:36 UTC.
This issue has been fully resolved.
Posted Oct 02, 2025 - 17:55 UTC

Monitoring

Provider Nuvei has an issue on their side.

We're currently experiencing issues with Provider Nuvei . Our team is actively investigating the matter and impact, and is in communication with the provider to resolve it.
Posted Oct 02, 2025 - 17:22 UTC
This incident affected: Providers \ Banks \ 3rd party integrations.